Error while installing vCenter 6.0 “Failed to Register Service in Component Manager”

SPOILER: Check your time sync between platform services controller and vCenter Server

I had this strange error while standing up two new vCenter Instances with a single external platform services controller.

vCenter Server Version: vCenter Server Update1b, Build 3343019
Operating System:           Windows 2012 R2
Deployment topology:   vCenter Server with an External Platform Services Controller.

The platform services controller installed fine, however whilst installing the two vCenter Servers I ran into the same error on both of them

"Unable to call to Component Manager: Failed to register service in Component Manager; url:http://localhost:18090/cm/sdk/?hostid=75fc9250-0c07-11e6-ac93-000c290481b4, id:b2646ddb-aa7a-4f2d-a2aa-37be891d6e49"

Unable to call to component manager

After that error, I would get the following.

"Installation of component VCSServiceManager failed with error code "1603". Check the logs for more details.

Capture1

Reviewing the installation logs showed the following

2016-04-27T09:35:25.317+10:00 [main ERROR com.vmware.cis.cli.CisReg] Operation failed
com.vmware.cis.cli.exception.ComponentManagerCallException: Failed to register service in Component Manager; url:http://localhost:18090/cm/sdk/?hostid=75fc9250-0c07-11e6-ac93-000c290481b4, id:b2646ddb-aa7a-4f2d-a2aa-37be891d6e49
at com.vmware.cis.cli.util.CmUtil.cmRegister(CmUtil.java:87)
at com.vmware.cis.cli.CisReg.registerService(CisReg.java:927)
at com.vmware.cis.cli.CisReg.doMain(CisReg.java:776)
at com.vmware.cis.cli.CisReg.main(CisReg.java:709)
Caused by: java.util.concurrent.ExecutionException: (cis.cm.fault.ComponentManagerFault) {
faultCause = null,
faultMessage = null,
errorCode = 0,
errorMessage = UNKNOWN
}
at com.vmware.vim.vmomi.core.impl.BlockingFuture.get(BlockingFuture.java:70)
at com.vmware.cis.cm.client.ComponentManagerClient.registerService(ComponentManagerClient.java:757)
at com.vmware.cis.cli.util.CmUtil.cmRegister(CmUtil.java:77)
... 3 more
Caused by: (cis.cm.fault.ComponentManagerFault) {
faultCause = null,
faultMessage = null,
errorCode = 0,
errorMessage = UNKNOWN
}
at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)

The logs weren’t exactly clear on why the installation was failing, but after some troubleshooting I noticed the timesync between the Platform Services Controller and the vCenter Servers were slightly out.  Once the timesync issues were resolved, the installation completed successfully.

In my case, I temporarily fixed the timesync issues by moving both the vCenter Servers and the PSC to a single host, and configuring VMware tools to sync time with the host which was configured to point to an external NTP server.

Share
  • aeron jones

    Creative writing , For what it’s worth , if your business is searching for a NY PUB-1301 , my assistant encountered a fillable document here https://goo.gl/Rjl991.